Follow-up[2]: pino-0.3+librest (and not cmake, at all)

So, after having troubles while trying to compile pino-0.3 it turns out is has nothing to do with cmake, nor with librest not shipping gir files but with vala bindings and incompability between those bindings from rest-0.6 and rest-0.7. So if I really want to compile pino-0.3 I have two options: use rest-0.6 or update rest.vapi for vala and send a patch for pino-0.3 to get a working code with rest-0.7 and it's new vala bindings...

But there's not enough free time for me this holidays so, maybe next time :-/

Anyway, thanks to all those who helped :)

Any comment goes best to my twitter here.